Note: The article in English is the reference for the other languages.
Issue
You do not receive Rainbow notifications on your Android device.
Root Cause
These Android devices or third-party applications have data, battery and RAM optimization mechanisms that can prevent Rainbow from sending notifications.
How to fix the issue
The settings to be checked may differ from one Android version to another and from one phone manufacturer to another. Some phone manufacturer have also some specific settings like application autostart that need to be set true for Rainbow.
Android operating systems
Android version 6.0.1+
Verify that the battery optimization is not preventing Rainbow from sending you notifications:
From the application drawer, open Settings.
Select Battery.
Open the Overflow menu icon and choose Battery Optimization.
Tap the downward caret and choose All apps.
Search and select Rainbow, then tap Don't optimize.
Android version 7+
From the application drawer, open Settings.
Select Apps.
Find and select Rainbow.
Select Battery, then open Battery Optimization.
At this point, select Apps not optimized option and modify it to All apps.
Search and select Rainbow and set to Don't optimize.
Android version 9
Verify that the the Adaptive Battery feature is not preventing Rainbow from sending you notifications:
From the application drawer, open Settings.
Select Battery.
Choose Adaptive Battery.
Select Restricted apps, and make sure Rainbow is not listed here.
OPPO
On OPPO devices you have to check different settings:
Setting 1: Verify that Rainbow is a protected application
From the application drawer, open Settings.
Select Advanced Settings.
Select Battery Manager, then open Protected Apps.
Select Rainbow to enable protection.
Setting 2: Verify that Rainbow is exclude from battery optimization
Open Settings.
Select Battery, then select Energy Saver.
Search Rainbow and verify that Freeze when in Background, Abnormal Apps Optimization and Doze are all disabled.
Setting 3: Verify that notifications are allowed for Rainbow
From the application drawer, open Settings.
Open Notification Panel & Status Bar.
Open Notification Center.
Activate allow notifications and priority display for Rainbow.
Setting 4: Verify that Rainbow is in the start up manager
Open the Security application.
Open Privacy Permissions, then Start up manager.
Ensure that this setting is enabled for Rainbow.
XIAOMI
On Xiaomi devices you have to check different settings:
Setting 1: Verify that Rainbow is allowed to autostart
From the application drawer, open Security.
Select Permissions.
Select Autostart.
Ensure that this setting is enabled for Rainbow.
Setting 2: Verify that Rainbow has no battery restriction
Open Settings.
Select Battery, then select Energy Saver.
Search Rainbow and verify that Freeze when in Background, Abnormal Apps Optimization and Doze are all disabled.
Setting 3: Verify that notifications are allowed for Rainbow
From the application drawer, open Settings.
Open Notification Panel & Status Bar.
Open Notification Center.
Activate allow notifications and priority display for Rainbow.
Setting 4: Verify that Rainbow is locked in the "recent applications" / "application overview" plane.
Open the application drawer, then select "recent apps/overview button"
Find Rainbow,pull down on it to "lock it"
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