Top

I Can't Start a Program Automatically when I Receive an Incoming Phone Call

Beantwortet

Kommentare

10 Kommentare

  • Quentin GRABENSTAETTER

    Below is an example of the syntax used to open a website when making an incoming phone call.

    In this example, I send the ${caller.phoneNumber} to a French reverse search directory "PagesJaunes".

    {
    "version" : "1",
    "extension-points" : {
    "on-incoming-pbx-call-actions" : [
    {
    "name" : "actionIn",
    "command" : {
    "url" : "https://www.pagesjaunes.fr/annuaireinverse/recherche?quoiqui=${caller.phoneNumber}&proximite=0"
    }}]}
    }

    The default web browser will be used to launch the search. No need to specify the application path.

    Let me know if this new example helps you! 😊

    1
    Aktionen für Kommentare Permalink
  • Quentin GRABENSTAETTER

    Hello, Samuel,

    Could you paste here the content of your "custo.manifest" and the content of the [Main] section of your "rainbow.ini" file?

    Thanks in advance,

    0
    Aktionen für Kommentare Permalink
  • Samuel DIRN

    Here is the content of the "custo.manifest" file:

    {
    "version" : "1",
    "extension-points" : {
    "on-incoming-pbx-call-actions" : [
    {
    "name" : "actionIn",
    "command" : {
    "url" : "C:\Program Files (x86)\MicroCRM\MicroCRM.exe",
    "params" : "-number ${caller.phoneNumber}"
    }}]}
    }

     Here is the content of the "rainbow.ini" file:

    [Main]
    language=en
    dwlFolder=C:\\Users\\sdirn\\Downloads
    shareCalendarInfo=true
    customizationDirectory=C:\\Program Files (x86)\\MicroCRM
    0
    Aktionen für Kommentare Permalink
  • Quentin GRABENSTAETTER

    Thank you for these information.

    Can you confirm that you restarted the Rainbow Desktop Application after editing the "rainbow.ini" file?

    The application must be reloaded to take into account the "rainbow.ini" file.

    0
    Aktionen für Kommentare Permalink
  • Samuel DIRN

    I'm more or less sure I rebooted but did it again today and now it works with microcrm.exe.

    Then I 've tried to open a web page but nothing happens. Here is my config:

    {
    "version" : "1",
    "extension-points" : {
    "on-incoming-pbx-call-actions" : [
    {
    "name" : "actionIn",
    "command" : {
    "url" : "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe https://www.editus.lu/en/search?q=${caller.phoneNumber}"
    } } ] }
    }

    Cheers

    Sam

    0
    Aktionen für Kommentare Permalink
  • Samuel DIRN

    Thank you. Indeed it works like this. Now what about mac app ?

    Sam

    0
    Aktionen für Kommentare Permalink
  • Quentin GRABENSTAETTER

    The behavior must be the same on Mac! Do you have an issue using this feature?

    Thanks in advance,

    0
    Aktionen für Kommentare Permalink
  • Samuel DIRN

    I just need to know where the rainbow.ini file is  on a mac

    Sam

    0
    Aktionen für Kommentare Permalink
  • Quentin GRABENSTAETTER

    No problem! On Mac, you will find the file "rainbow.ini" in the folder below:
    ~/.config/Alcatel-Lucent Enterprise/Rainbow

    To find it easily, you can use the "Go" link on the top bar and choose "Go to Folder".

    Regards,

    0
    Aktionen für Kommentare Permalink
  • Fabio COSTA

    Hello Quentin, 

    I'm trying to do the same as you , but it don't work... when a customise the file "settings" and when i restart Rainbow  all my change disappear... I'm  in rainbow  2.80.11 release, does it work in this release? 

     

    0
    Aktionen für Kommentare Permalink

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.

Sie können immer noch nicht finden, was Sie brauchen?

  • Kontaktieren Sie uns

    Haben Sie eine Frage zu Rainbow? Hinterlassen Sie uns eine Nachricht, um weitere Informationen zu erhalten.

    Kontakt
  • Fragen Sie die Gemeinschaft

    Brauchen Sie Hilfe? Stellen Sie Ihre Fragen in der Community, um Antworten von anderen Rainbow-Benutzern zu erhalten.

    Nachricht posten