Note: The article in English is the reference for the other languages.
Issue
When I want to call a colleague, only his DDI phone number is displayed, but I want to call him on his internal (short) phone number. Why is this number not offered as a phone number ?
Root Cause
Once a Rainbow account is associated with its PBX device and if a DDI is configured on his account then only that DDI number will be displayed in the Call Menu.
How to fix the issue
In fact, even if only the DDI is displayed, an internal call will be made automatically according to the following rule:
- When adding a PBX to a Rainbow company, this PBX will be associated to a "group of PBXs".
- Any other PBX connected to this company will be added to the same "PBX group".
- Each time you make a call, Rainbow will check to see if both users are on a PBX belonging to the same PBX group and if so, an internal call will be made despite the call menu shows only the DDI Phone number.
Important: In case several PBXs are connected to the same company, it is mandatory to have a homogeneous numbering plan and you must ensure that the internal numbers are well routed between the PBXs (each user of each PBX must be reachable on his internal (short) number).
Note: Specific behavior for OTEC-S which are not added to a PBX group, the rule that applies to decide to make an internal call in this case is to check if the caller and the called party have a short number that is part of the same prefix range in the OTEC-S.
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