Issue description:
The article How to Find My Logs describes how to retrieve the logs when you are connected to the Rainbow app, but in some cases you can't connect to the app and are not able to use the feature send/open logs from the application.
Root cause:
Various problems may prevent you from connecting to the application.
How to fix the issue:
Select you app:
Rainbow Desktop app (Windows)
- Application log files are located in the user's local temp folder.
To access any user’s Local temp folder, type the following variable either in Windows Explorer’s Address Bar or from Start -> Run (WinKey + R):
Then open the Rainbow folder located into \Temp\Alcatel-Lucent Enterprise\
Select all files and make them into a zip archive.
If you have activated the Rainbow add-in for Outlook® you may have to close Outlook® before making the zip archive.
- You can also find some installation log files located in the user's roaming folder.
To access any user’s Roaming AppData folder, type the following variable either in Windows Explorer’s Address Bar or from Start -> Run (WinKey + R):
Then open the Rainbow folder located into \Roaming\Alcatel-Lucent Enterprise\
Select all "Setup Log xxxx-xx-xx #xxx.txt" files and make them into a zip archive.
Rainbow Desktop app (MacOS)
- Application log files are located in the Application Support folder.
Open the Go to Folder menu
Go to folder: ~/Library/Application Support/Alcatel-Lucent Enterprise/Rainbow
Select all files and make them into a zip archive.
- You can also find some installation log files located in the following application config folder.
Open the Go to Folder menu
Go to folder: ~/.config/Alcatel-Lucent Enterprise/Rainbow
Select all files and make them into a zip archive.
Rainbow Android app
- Rainbow Android application log files can't be retrieved as such (since version 1.57.5). But you can still access to the option to send the logs:
Go to Android option of Rainbow app and select "Storage"
Depending of the Android version open either "Manage Space" or "Clear Storage"
You're now in the Rainbow Settings menu where under "Advanced settings" you'll find the Send log option.
Rainbow iOS app
- Rainbow iOS application log files can't be retrieved as such:
- If you can't connect but you're able to open Rainbow login screen you can display the option to send the logs by email by quickly shaking the phone.
- If you can't access to login screen you can provide iOS logs about the Rainbow application:
Open iOS Settings menu and navigate to Privacy >> Analytics
Open "Analytics Data"
Then search for the Rainbow files (files starting with Rainbow-), open each file corresponding to the date and time of the issue and share the file for example with your email client.
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