Issue
Incoming calls:
Some incoming local calls are incorrectly displayed in the call log. Instead of the local number, I have the local number with the country code in front of it.
Outgoing calls:
Similar issue occurs when I dial a local phone number.
But if I dial the same number with the area code it will work; let's say the area code is 030 and dialing 0306547891 will work.
Root Cause
For incoming and outgoing calls the issue is linked to the same mechanism used in Rainbow to validate the phone number format:
The number received or dialed is send to a phone library and some times the number will be qualified wrongly as national number. In the example above the library may found in the number 6549871 that 65 (or 065) is an existing and valid area code and that therefore 06547891 is a valid national number (at least what concerns the format).
Incoming calls:
the issue occurs because Rainbow receives the local number without the area code from the PBX and has validated it as national number. For incoming calls Rainbow displays a national number in canonical format therefore we will see +496549871.
Outgoing calls:
for outgoing calls and the fact that the number has been validated as national number by the phone library Rainbow will add the outbound prefix + the number in national format. If outbound prefix is e.g. 0 Rainbow will send to the PBX the number 006547891 instead of 06547891.
How to fix the issue
Incoming calls:
OXO Connect or OXO Connect Evolution:
If the trunk provider sends to the OXO/OCE the local number with the area code and if this area code is well configured into OXO/OCE "Installation numbers" menu (value Intercity Prefix) then the PBX will remove this prefix automatically.
OmniPCX Enterprise, OXO Connect and OXO Connect Evolution:
In case the number received on the PBX Trunk doesn't contain the area code the you'll have to check if maybe receiving the local number with area code can be configured on the Session Border Controller (or any similar equipment providing the trunk to the PBX) and if not you'll have to check directly with the trunk provider if he can change the format of the local number send to your PBX.
Outgoing calls:
The issue for outgoing calls can be solved by adding some dialing rules to the PBX configuration into Rainbow. This is valid for OmniPCX Enterprise (OXE) and OXO Connect or OXO Connect Evolution (OCE).
You need to create a rule to detect a local number and add the area code to this number. Starting point is to know what maximum length are your internal numbers and construct the rule with this information.
Let's say internal numbers are never longer then 4 digits, area code is 030 and outbound prefix is 0 with this information the rule to detect local numbers will be:
Replace: 0030$1
- First ^ is to for "String starting with"
- [^0|+] is to for "Not starting with + or 0"
- \d{4,} is for "only digits" (\d) and more then 4 digits {4,}
Replace will add in front of the number the 0 for the outbound prefix and 030 for the area code.
Rule: ^(\d{1,4})$
Replace: $1
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